Logon Process to OMA55 Results in Error 500 (301560)



The information in this article applies to:

  • Microsoft Mobile Information 2001 Server

This article was previously published under Q301560

SYMPTOMS

When you log on to Microsoft Outlook Mobile Access for Exchange Server 5.5 (OMA55) and the server is running the Microsoft Exchange 5.5 Data Access component of Microsoft Mobile Information Server 2001, you encounter a "500 Server Error" message after you go to the http://mmisserver/oma55 Web page, enter your user name and password, and then press ENTER. You cannot access the mailbox and "Error 500" errors are recorded in the W3SVC logs for Microsoft Internet Information Server (IIS) in Microsoft Mobile Information Server.

No events are generated in the Application log or the System log in Exchange Server 5.5 or in Microsoft Mobile Information Server.

CAUSE

This behavior occurs because OMA55 is not supported on a domain controller or on a Global Catalog (GC) server.

RESOLUTION

To resolve this behavior, remove Mobile Information Server from the domain controller and/or the GC server, and then reinstall it on a member server.

MORE INFORMATION

Because of the Name Services Provider Interface (NSPI) provider that is running on either the domain controller or the GC server on which OMA55 is installed, OMA55 will experience difficulties when it tries to communicate with the Directory Services interface. This communication difficulty causes authentication failures in OMA55 when it tries to contact the Exchange Server 5.5 by use of a remote procedure call (RPC) or Collaboration Data Objects (CDO) to retrieve the mailbox.

256976 XCLN: How MAPI Clients Access Active Directory

275127 XADM: How to Configure Exchange Server 5.5 to Run on a Domain Controller or Global Catalog


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB301560