FP2000: Error Message When You Install FrontPage Server Extensions: Conflict on Port 80 (301446)



The information in this article applies to:

  • FrontPage 2000 Server Extensions from Microsoft

This article was previously published under Q301446

SYMPTOMS

When you attempt to install FrontPage 2000 Server Extensions on FrontPage Personal Web Server, you may receive an error message similar to the following:
Conflict on port 80

CAUSE

This issue can occur when there is another Web server installed on your computer and that web server is configured to use port 80. For example, you have FrontPage Personal Web server and Microsoft Personal Web Server running on your computer and both are configured to operate on port 80.

RESOLUTION

To resolve this issue, use the method that is appropriate to your situation.

Method 1

To run two Web servers on the same computer, each Web server must be configured to use a different port. If you want to run FrontPage Personal Web Server and another Web server on your computer, edit the Httpd.cnf file to configure the Front Page Web Server and FrontPage Server Extensions to use port 8080. To do this, follow these steps:
  1. Start FrontPage Server Administrator (Fpsrvwin.exe).
  2. Click 80 in the Select server or port list, and then click Uninstall to remove the FrontPage Server Extensions from port 80.
  3. Start Notepad, and then open the Httpd.cnf file.

    Httpd.cnf is the main server configuration file for FrontPage Personal Web Server. It is located in the \FrontPage Webs\Server\Conf folder.
  4. Locate the following entry: port 80
  5. Change it to the following: port 8080
  6. Click Save on the File menu.
  7. Start FrontPage Server Administrator (Fpsrvwin.exe).
  8. Click Install to install FrontPage Server Extensions.
  9. In the Server type list, click FrontPage Personal Web Server, and then click OK.
  10. In the Server Configuration dialog box, click Browse.
  11. Locate the \FrontPage Webs\Server\Conf\Httpd.cnf file, click Open, and then click OK.
  12. Type a user name and password, and then click OK.
FrontPage Personal Web Server and the FrontPage Extensions are now configured to use port 8080, and the other Web server installed on your computer remains configured to use the default Hypertext Transfer Protocol (HTTP) port, port 80. To browse to any of your existing content on the FrontPage Personal Web Server, you must specify the port number in addition to the server name in the URL. For example, if the name of your computer is MyComputer, type the following:

http://MyComputer:8080

Method 2

Remove FrontPage Personal Web Server and the FrontPage Server Extensions. Before you remove FrontPage Personal Web Server, ensure that you either back up the Web content that you want or copy the Web content to your other Web server. To remove FrontPage Personal Web Server and FrontPage Server Extensions, follow these steps:
  1. Start FrontPage Server Administrator (Fpsrvwin.exe)
  2. Click 80 in the Select server or port list, then click Uninstall to remove the FrontPage Server Extensions from port 80.
  3. Start Windows Explorer, and then browse to the x:\FrontPage Webs folder (where x is the drive where FrontPage Personal Web Server is installed).
  4. Delete the x:\FrontPage Webs folder.

MORE INFORMATION

For additional information about installing FrontPage Server Extensions on FrontPage Personal Web Server, click the article number below to view the article in the Microsoft Knowledge Base:

266369 FP2000: Error Message: No Server on Port 'Number' at 'Server Name'

For additional information about FrontPage Personal Web Server, click the article numbers below to view the articles in the Microsoft Knowledge Base:

194355 FP98: Why Are There Two Versions of the Personal Web Server?

194543 FP98: When to Use the FrontPage Personal Web Server Vs. the Microsoft Personal Web Server


Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbprb KB301446