An Error Message May Be Displayed When You Use Terminal Services and the Print to File Feature in Application Mode (301444)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
This article was previously published under Q301444 SYMPTOMS
If you use Terminal Services and attempt to use the "Print to file" feature in Application mode, and your file is targeted to a mapped drive letter that points to a writeable share, you may receive the following error message:
There was an error found when printing "filename"
to [driveletter:\path]. Do you want to Retry or Cancel?
If you press Cancel, you may receive the following error message:
Start doc printer call was not issued.
A zero-length file is created on the target path.
CAUSE
This problem can occur because during a Terminal Services server client session the access to the drive mappings is not inherited by the Spoolsv.exe program from the user.
RESOLUTION
To resolve this problem, use the universal naming convention (UNC) path to the location that the mapped drive points to, or write the file to a local folder, and then copy the file to the mapped drive.
To use the UNC path, type in the complete UNC path of the file name when you are prompted for "Output File Name:". For example,
UNC format: \\ServerName\ShareName\FileName
Example: \\WinSrv1\Share1\TestPrint.prn, where "WinSrv1" is the server name, "Share1" is the share name, and "TestPrint.prn" is the resulting print file name.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 1/27/2006 |
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Keywords: | kbenv kberrmsg kbnofix kbprb kbprint KB301444 |
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