SYMPTOMS
When you start Microsoft Train Simulator, you may receive
the following error message:
Microsoft Train Simulator
has encountered a problem and needs to close. We are sorry for the
inconvenience.
If you click
Click Here, a second dialog box that contains information about the error
opens. The information contains one of the following:
Error Signature
AppName: train.exe AppVer: 1.16.5.912 ModName: D3Dim700.dll
ModVer: 4.8.0.400 Offset: 00015eae
Error Signature
AppName: train.exe AppVer: 1.16.5.912 ModName: train.exe
ModVer: 1.16.5.912 Offset: 002b0503
Error Signature
AppName: train.exe AppVer: 1.16.5.912 ModName: train.exe
ModVer: 1.16.5.912 Offset: 002ad896
CAUSE
This behavior can occur if any of the following conditions
are true:
- Your video driver is incompatible with DirectX 7.0 or
later.
- Your computer video card is using outdated drivers.
- Your video card does not meet the minimum memory
requirements.
For a list of video chip sets and cards that have exhibited
this behavior, see the "More Information" section of this article.
RESOLUTION
Verify that your drivers are compatible with DirectX 7.0 or
later. To do this, follow these steps:
- On the Windows Start menu, click Run.
- In the Open box, type dxdiag.exe, and then click OK.
- Click Save All Information.
- In the Save In box, click Desktop, and then click Save.
- Click Exit.
- Open the Dxdiag.txt file on your desktop.
- In the Display Devices section, locate the DDI Version line. The version listed here
must be at least 7 for the game to function correctly. The DDI version is a
reference to your video drivers.
If your drivers are compatible with DirectX 7.0 or later,
download and install an updated video card driver.
For information about how to contact your video card, click the
appropriate article number in the following list to view the article in the
Microsoft Knowledge Base:
65416 Hardware and Software Third-Party Vendor Contact List, A-K
60781 Hardware and Software Third-Party Vendor Contact List, L-P
60782 Hardware and Software Third-Party Vendor Contact List, Q-Z
To identify the manufacturer and model of your
video adapter, follow these steps:
- On the Windows Start menu, point to Settings, and then click Control Panel.
- Double-click System.
- Click the Device Manager tab.
- Expand (click the plus sign next to) the Display Adapters folder.
- Note the manufacturer and model of your video adapter, and
then click OK.
- Close Control Panel.
After installing the updated video drivers Train Simulator must
redetect the adaptor.
- To open the Troubleshooter, point to Start, point to Programs, point to Microsoft Games, point to Train Simulator, and then click on Train Simulator
Troubleshooter.
- Click Change Video Driver.
- Click to select the new driver from the drop down list and
click OK.
- Exit the troubleshooter and start Train Simulator
normally.
Verify that your video card has at least for 4 megabytes (MB)
of memory. To determine how much video memory is installed on your video card,
use the DirectX Diagnostic Tool (Dxdiag.exe). To do this, follow these steps:
- On the Windows Start menu, click Run.
- In the Open box, type dxdiag.exe, and then click OK.
- Click the Display tab.
- In the Device section, look for the Approx. Total Memory option and note the total amount of memory installed on your
video adapter.
- Click Exit.
If less than 4 megabytes (MB) of video memory are installed on
your video adapter, install additional video memory on your video adapter, or
install a video adapter with more video memory.
An update has been
created to resolve some compatibility problems with several video cards. To
download and install the update, visit the following Microsoft Web site:
Install Update
An update has been created to resolve some compatibility problems
with several video cards. To download and install the update, visit the
following Microsoft Web site:
To resolve the issue with Diamond Speedstar A50 based on SIS 6326
chipset, install reference drivers. To do so, visit the following SIS Web site: