No Logging Shows in MA Form When zcDsLogControl Attribute in Replica Lacks Drive Letter (300906)
The information in this article applies to:
- Microsoft Metadirectory Services 2.2
- Microsoft Metadirectory Services 2.2 SP1
This article was previously published under Q300906 SYMPTOMS
The replication log file may be reported to be zero bytes long in the Consumer Replication Agreement form, even though this may not be the true size of the log.
CAUSE
On the Launch Replication Agreement action of an Microsoft Metadirectory Services (MMS) replication agreement, the replication log (and its size) are displayed in the zcDsLog window. The zcDsLogControl replication agreement attribute holds the path to this log. The zcDsLogControl attribute does not specify the drive letter of the log file, so there is no way for the client to know which drive on the server holds the log file.
In MMS 2.2 and MMS 2.2 Service Pack 1 (SP1), the default server drive is incorrectly set to drive C. If the MMS server has been installed on any drive other than drive C, the server cannot find the log file, and returns a file size of 0 bytes.
RESOLUTION
To work around this problem:
- In the MMS Compass client, log into MMS as an administrator.
- Using the Bookmarks action, select the Management Agents bookmark.
- Using the Actions action, select the server icon and display its properties.
- Click the Available Management Agents tab.
- Record the drive letter that is displayed under Server Working Directory. The display looks similar to this example, where E is the drive letter:
- Click OK to close the form.
- Using the Bookmarks action, select the Replication Agreements bookmark.
- Using the Actions action, select the appropriate Replication Agreement icon and display its properties.
- The zcDsLogControl attribute is displayed under Replication Agreement Log Path, and it contains a string that is similar to following string:
zoomserv\data\logs\syn72292.log - Insert the drive letter, colon and backslash from step 5 so that something like the following appears:
drive letter:\zoomserv\data\logs\syn72292.log - Click OK to close the form.
- The log now displays correctly in the Launch Replication Agreement form.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 6/5/2003 |
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Keywords: | kbenv kbprb kbui KB300906 |
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