Internal Web clients are unable to access an externally-hosted Web site (300679)
The information in this article applies to:
- Microsoft Windows Small Business Server 2003, Premium Edition
- Microsoft Windows Small Business Server 2003, Standard Edition
- Microsoft Small Business Server 2000
This article was previously published under Q300679 SYMPTOMS
Internal clients on a Small Business Server (SBS) domain are able to browse to all external Internet sites except for your company's own registered domain name. For example, if your company's domain name is "mycompany.com", internal clients would be able to view all Web sites except for "mycompany.com".
CAUSE
This behavior can occur if you have chosen your registered Internet domain name as your internal Active Directory DNS name space, and your registered Internet domain name is hosted and managed by an external entity, such as an ISP.
When you install Active Directory, it creates a DNS zone for your Active Directory domain on your DNS server. The DNS server is configured to be authoritative for that zone. Properly configured client computers are configured to use the SBS DNS server to resolve names. If the name that a client computer is trying to resolve is in a domain that is not on the SBS server, that request is forwarded to another upstream DNS server for resolution. If the SBS server has a zone that is configured for that domain, the SBS server will resolve that request locally. However, if no record exists on the SBS server, the client's request fails.
RESOLUTION
To resolve this behavior without having to reconfigure your Active Directory, you can create records in your zone that match records that are created at the external DNS server. For example, you could create a host (A) record for "WWW" in your mycompany.com zone that resolves to the external IP address of the ISP-hosted Web server.
To create DNS records:
- Start DNS Manager by clicking Start, pointing to Programs, pointing to Administrative Tools, and then clicking DNS.
- Expand your server branch, and then expand the Forward Lookup Zones branch.
- Expand the DNS name zone.
- On the Action menu, click New Host, and then type the name www (or other host name) in the New Host dialog box.
- Type the IP address of the host. You can obtain this information by contacting your ISP, or by using the ping command from a computer that is not on your network. For example, you could ping www.mycompany.com from a computer on the Internet, and it should resolve with an IP address. You may want to confirm this address with your ISP. ISP-managed IP addresses are subject to change. If this happens, you will need to update the A record you created for "www" in your DNS zone.
STATUSThis behavior is by design.REFERENCES
Modification Type: | Major | Last Reviewed: | 6/14/2004 |
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Keywords: | kbnetwork kbprb KB300679 |
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