You receive a "Microsoft Office XP requires updated system files not detected on your computer" when you install Office XP (300582)



The information in this article applies to:

  • Microsoft Access 2002
  • Microsoft FrontPage 2002
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Excel 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q300582

SYMPTOMS

When you install Office XP, you may receive one of the following error messages:
Error 25506. Microsoft Office XP requires updated system files not detected on your computer. You must install the System Files Update prior to installing Office. C:\Windows\HH.exe is version 4.72.7322.0 when we require version 4.73.8412.0.
Error 25506. Microsoft Office XP requires updated system files not detected on your computer. You must install the System Files Update prior to installing Office. C:\Windows\System\ITSS.dll is version 4.72.7309.0 when we require version 4.72.8084.0.
Error 25510. Microsoft Office XP requires updated system files not detected on your computer. You must install the System Files Update prior to installing Office. C:\Windows\HH.exe is missing when we require version 4.73.8412.0.
Error 25510. Microsoft Office XP requires updated system files not detected on your computer. You must install the System Files Update prior to installing Office. C:\Windows\System\ITSS.dll is missing when we require version 4.72.8084.0.
Error 25510. Microsoft Office XP requires updated system files not detected on your computer. You must install the System Files Update prior to installing Office. C:\Windows\System\ITIR.dll is missing when we require version 4.72.7276.0.
Error 25506. Microsoft Office XP requires updated system files not detected on your computer. You must install the System Files Update prior to installing Office. C:\WINNT\HH.EXE is version 4.73.8252.0 when we require version 4.73.84.8412.0.
When you run Office Setup again and repair the System Files Update installation, you continue to receive the error message.

CAUSE

These error messages can appear if the files mentioned in the error messages are missing, or if the versions of these files on your computer are earlier than the versions mentioned in the error messages.

RESOLUTION

To resolve this problem, use one of the following methods.

Method 1: Update Your Computer with the Latest HTML Help Runtime Files

Visit the following Microsoft Web site, and then download the update that is described in Security Bulletin: MS02-055 to obtain the latest HTML Help Runtime files for your version of Microsoft Windows: NOTE: You can install the latest HTML help Runtime files from the Microsoft Windows Update Web site. To have the Microsoft Windows Update Web site scan your computer, and then install the latest updates, visit the following Microsoft Web site. Microsoft recommends that you visit the Microsoft Windows Update Web site regularly to ensure that you have the latest updates available for your computer.

Method 2: Extract the HTML Help Files from the .Cab File

If you do not have Internet access, you can resolve this problem by manually extracting the HTML Help files from the Hhupd.cab file on your Office XP CD. To do this, follow these steps:
  1. Using Windows Explorer, open the \Files\OSP\1033\IE5\EN folder on your Office XP CD.
  2. Double-click Hhupd.cab.
  3. In the window that lists all of the files contained in Hhupd.cab, click Select All on the Edit menu.
  4. On the File menu, click Extract.
  5. In the Browse for Folder dialog box, select the desktop and then click OK.
  6. On your desktop, right-click Hhupdcab.inf and then click Install. This installs all of the necessary HTML Help files.
  7. Run Office XP Setup again.

MORE INFORMATION

For additional information about similar error messages, click the article numbers below to view the articles in the Microsoft Knowledge Base:

301064 OFFXP: Error 25506, Asycfilt.dll Is Wrong Version Running Setup

304629 OFFXP: Error 25506 on ODBCBCP.DLL, SQLSRV32.DLL, ODDBSE32.DLL, ODBCJI32.DLL, MSORCL32.DLL

For more articles about troubleshooting Setup issues with Office XP:

Modification Type:MajorLast Reviewed:10/8/2006
Keywords:kbtshoot kberrmsg kbnofix kbprb KB300582