Internet Explorer Does Not Cache a Proxy Server That Is Assigned By an Autoconfiguration File (300534)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 1
  • Microsoft Internet Explorer 5.01 for Windows 98 Second Edition SP 1
  • Microsoft Internet Explorer 5.01 for Windows 98 Second Edition SP 2
  • Microsoft Internet Explorer 5.0 for Windows 98 Second Edition
  • Microsoft Internet Explorer 5.5 for Windows 98 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.5 for Windows 95 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 5.5 for Windows 2000 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 2000

This article was previously published under Q300534

SYMPTOMS

When you are connected to the Internet through a proxy server that is referenced in a .pac file that was created by using the Microsoft Internet Explorer Administration Kit (IEAK), and the server that is hosting the autoproxy file loses connectivity, you may still be able to access Internet sites. However, after you quit Internet Explorer, you may be unable to access the Internet.

CAUSE

This behavior can occur when Internet Explorer is configured to use both the autoconfiguration and the autoproxy feature. In this configuration, Internet Explorer caches the .pac file from the server. If you restart Internet Explorer, the cache is flushed and you can no longer connect. Internet Explorer does not permanently cache the autoproxy server setting or the .pac file when the IEAK autoconfiguration feature is used.

RESOLUTION

To work around this behavior, manually choose your proxy settings, or use the "Automatically detect settings" feature in Internet Explorer:
  1. In Internet Explorer, click Internet Options on the Tools menu.
  2. Click the Connections tab, and then click LAN Settings.
  3. Click to select the Automatically detect settings check box, click OK, and then click OK.
For additional information about how to configure Internet Explorer to use a proxy server, click the article number below to view the article in the Microsoft Knowledge Base:

135982 How to Configure Internet Explorer to Use a Proxy Server

STATUS

This behavior is by design.

MORE INFORMATION

When Internet Explorer is configured to use a .pac file, it caches the proxy that is returned by the FindProxyForURL call. If the Web server where the .pac file is located loses its connection to the network, the client computer is still able to access Internet sites because the proxy server that is currently in use is being cached as long Internet Explorer is running. However, after Internet Explorer has been restarted, Internet Web sites cannot be reached if the Web server that contains the .pac file is still unavailable. This behavior occurs because neither the autoproxy file or the proxy server that was previously used has been permanently cached.

Also, if Internet Explorer uses both the autoconfiguration and the autoproxy feature, the autoproxy feature does not work when the Web server that is holding the autoconfig (.ins) files is not available after a restart of Internet Explorer. This occurs also when the autoconfiguration (.ins) and autoproxy (.pac) files are based on different Web servers, because the autoproxy setting in Internet Explorer is not being cached permanently when autoconfiguration is being used.

Modification Type:MajorLast Reviewed:11/26/2003
Keywords:kbenv kbnetwork kbprb KB300534