Visio2000: Cannot Open a Newly Saved File (300209)



The information in this article applies to:

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q300209

SYMPTOMS

When you attempt to open a drawing that you recently saved, the drawing file does not open successfully. You receive an error message similar to the following:
Error 3400
General OLE error.

CAUSE

The computer was turned off while the file was still in the write-caching buffer. As a result, the file was not completely written to the hard disk.

RESOLUTION

To resolve this behavior, do one of the following:
  • Wait until you are sure that your computer is finished saving files before you turn the power off.

    -or-
  • Save the file to removable media, such as a floppy disk.

    -or-
  • Create a .zip file of the Visio drawing file, immediately after you save the file. This ensures that the operating system completely saves the contents of the write-caching buffer.

MORE INFORMATION

If you are saving your drawing to a network share point, consider saving the file to the local hard disk first, and then copying it to the share point. This ensures that the file is correctly saved locally before you turn the computer off.

Consider downloading the Visio 2000 Update at the following Microsoft Web site:

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

278261 Visio2000: Error 100 When You Open a Drawing After Abnormal Termination


Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kberrmsg kbprb KB300209