Visio2002: Devices Display Incorrect Connections in Your Network Diagram After You Perform a Rediscovery (300015)



The information in this article applies to:

  • Microsoft Visio 2002 Professional
  • Microsoft Visio Network Central
  • Microsoft Visio Enterprise Network Tools

This article was previously published under Q300015

SYMPTOMS

After you use the AutoDiscovery and Network solution in Microsoft Visio to rediscover your network devices, some devices may not show correct connections to other devices in your network diagram.

CAUSE

This behavior can occur if all of the following conditions are true, in the order in which they are presented:
  1. You perform a network discovery and create a network diagram.
  2. A cable change is made to a device in your network.
  3. You rediscover your network immediately after the cable change is made.
  4. You add the device (in which the cable change was made) to your network diagram.
When you rediscover your network immediately after a cable change is made to a device (or devices) on your network, Visio does not correctly handle the way in which layer-2 connectivity is related to layer-3 devices. As a result, incorrect information about the device (or devices) and their interconnectivity may be written to the AutoDiscovery database, and the device (or devices) may not show correct connections to other devices in your network diagram.

RESOLUTION

To work around this issue, delete the incorrectly connected layer-2 devices from your database, and then rediscover the devices. To do this, follow these steps:
  1. Start Visio, and then open your network diagram.
  2. On the AutoDiscovery menu, point to Database Viewer, and then click Open/Close.
  3. In the Database Viewer, double-click the device type to expand the group, and then view the device (or devices) in the right pane.
  4. Right-click the device that you want to remove, and then click Delete.

    The device is now placed in the Deleted group.
  5. To permanently delete the device, double-click the Deleted group, right-click the device, and then click Delete.
  6. Point to Database Viewer on the AutoDiscovery menu, and then click Open/Close to close the Database Viewer.
  7. On the AutoDiscovery menu, point to Discovery, and then click Discovery Wizard to start the Discovery Wizard.
  8. Follow the instructions on the wizard pages to rediscover your network devices.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information about discovering your network and creating network diagrams in Microsoft Visio, type autodiscovery in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

For more information about the Database Viewer in Microsoft Visio, type database viewer in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbpending KB300015