Visio2002: Network Reports Based on the AutoDiscovery and Layout Solution Are Missing Data (300006)



The information in this article applies to:

  • Microsoft Visio 2002 Professional
  • Microsoft Visio Enterprise Network Tools
  • Microsoft Visio Network Central

This article was previously published under Q300006

SYMPTOMS

When you attempt to view a network report that is based on data from an AutoDiscovery database in Microsoft Visio, the report data is missing. The report contains only a header.

CAUSE

This problem occurs because the AutoDiscovery and Layout solution is not installed. To view network reports based on an AutoDiscovery database in Visio, the AutoDiscovery and Layout solution must be installed from the Microsoft Visio Enterprise Network Tools CD. Without AutoDiscovery and Layout, the reports contain only header information.

RESOLUTION

To resolve this problem, install the AutoDiscovery and Layout solution. The AutoDiscovery and Layout solution in Enterprise Network Tools requires Microsoft Visio Professional 2002, and also the following components installed on your computer:
  • Microsoft Data Engine (MSDE)
  • Windows Management Instrumentation (WMI)
  • Visio Enterprise Network Tools

Microsoft Data Engine (MSDE)

If MSDE is not already installed, follow these steps:
  1. Start Windows Explorer, and then navigate to the \MSDE2000 folder on your Enterprise Network Tools CD.
  2. Double-click Setup.exe.
  3. When Setup is complete, restart your computer.

    Note that an MSDE icon is added to the system tray.

Windows Management Instrumentation (WMI)

If you are running Microsoft Windows 2000 or Microsoft Windows Millennium Edition (Me), WMI is installed by default with the operating system. If you are running Microsoft Windows 98 or Microsoft Windows NT 4.0, install WMI from the \WMI_agents folder of your Enterprise Network Tools CD. To do this, follow these steps:
  1. Start Windows Explorer, and navigate to the \WMI_agents folder on your Enterprise Network Tools CD.
  2. Double-click the folder appropriate for your operating system, and then double-click Wmixx.exe, where xx represents your operating system.

Visio Enterprise Network Tools

  1. Insert the Enterprise Network Tools CD in your CD-ROM drive.
  2. If the CD does not start automatically, double-click My Computer on your desktop, double-click your CD-ROM drive, and then double-click Autorun.exe.
  3. On the Welcome page, click Next.
  4. On the License Activation page, select the appropriate user option, and then click Next.
  5. Enter your Product Key, and then click Next.
  6. Click to select the I accept the terms in the License Agreement check box, and then click Next.
  7. On the Install Center page, click to select the AutoDiscovery and Layout check box, and then click Install.
  8. In the Welcome to Microsoft Visio Enterprise Network Tools dialog box, type your user information, and then click Next.
  9. Click Install Now!.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

With the AutoDiscovery and Layout solution, you can create tabular and textual reports on the status of your network based on data from your AutoDiscovery database. You can quickly inventory IP addresses, summarize frame relay data, track changes to your network topology, and more. Reports are generated as Microsoft Visio drawings (.vsd files), and you can easily publish them to the Web.

For more information about installing Enterprise Network Tools, please refer to the documentation on the Microsoft Visio Enterprise Network Tools CD.

For more information about AutoDiscovery and Layout in Microsoft Visio, type AutoDiscovery in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbpending KB300006