SNA Server/HIS client logon fails after prompting for new password (298892)



The information in this article applies to:

  • Microsoft SNA Server 4.0
  • Microsoft Host Integration Server 2000

This article was previously published under Q298892

SYMPTOMS

If a user's Windows NT or Windows 2000 domain password expires, the Windows 9x Client for SNA Server 4.0 will display a "Logon Failed" message when a session is initiated after the user changes the password. The Host Integration Server (HIS) 2000 End User Client displays the following error message:
Error: Could not open sponsor connection" message after the password is changed.
After the Windows NT or Windows 2000 password is successfully changed, the user is able to connect to the SNA Server or HIS 2000 server if the SNA Server or HIS client application is restarted.

CAUSE

SnaBase was not able to successfully perform a new logon attempt after the user's domain password was changed.

RESOLUTION

To resolve this problem, obtain the latest service pack for Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

328152 How to obtain the latest Host Integration Server 2000 service pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Host Integration Server 2000 Service Pack 1.

MORE INFORMATION

If the Use Windows Domain Password option is not selected in the SNA Server Windows 9x or HIS 2000 End User client, a domain logon information pop-up dialog box is presented when the client connection is initiated. If the user's domain account has been set for "user must change password at next logon" or the account password has expired, a password change dialog box will be presented.

Modification Type:MinorLast Reviewed:4/27/2005
Keywords:kbbug kbfix kbHostIntegServ2000preSP1fix kbHostIntegServ2000SP1fix KB298892 kbAudDeveloper