PRB: Population or Query of a Full Text Catalog May Stop Responding (298794)
The information in this article applies to:
- Microsoft SQL Server 7.0
- Microsoft SQL Server 2000 Standard Edition
This article was previously published under Q298794 SYMPTOMS
An attempt to populate or query a large full text catalog may stop responding (hang).
Also, queries and maintenance activities against the catalog may become unresponsive.
CAUSE
Virtual memory for the MSSEARCH process space is exhausted by the catalog caching operations.
RESOLUTION
The DWORD key MaxPropStoreCachedSize, in the HKLM\Software\Microsoft\Search\1.0\Indexer registry path, controls the amount of memory in megabytes (MB) that a catalog caches.
Adjust the MaxPropStoreCachedSize value accordingly to ensure proper virtual address space usage. Also, be cautious because a reduction in the cache size may affect performance.
IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
MORE INFORMATION
To determine if you are encountering the problem monitor the "Virtual bytes" performance counter in the "Process" group for Mssearch.exe. If the "Virtual bytes" value approaches the processes virtual memory limitation, then you are most likely experiencing the condition that causes a query to stop responding.
Calculate the number of active catalogs times the MaxPropStoreCachedSize and see if the value calculated approaches the process virtual memory limit.
Modification Type: | Minor | Last Reviewed: | 7/16/2004 |
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Keywords: | kbprb KB298794 |
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