Logon Problems with 10/100 Ethernet Hubs and Switches (298733)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 98
  • Microsoft Windows Millennium Edition
  • Microsoft Windows NT Server 4.0

This article was previously published under Q298733

SYMPTOMS

When you try to log on from your client computer that is connected to an 10/100 Ethernet hub with a 10/100 autosensing Ethernet adapter installed, you may receive one or more of the following error messages:
  • No domain controller was available to validate your logon. You have been logged on with cached credentials.
  • No domain controller was found to validate your password.
  • No domain controller was found to validate your account.
  • No domain controller found or domain does not exist.
Although this behavior may be corrected by restarting your computer, you may still be unable to determine a pattern of successful connectivity.

CAUSE

This issue can occur if the Ethernet adapter media type is set to autosense, autosensing, or autodetect. This usually occurs when the network topology consists of switches that have autosensing capabilities. The lack of proper media type detection may cause a timeout in the NetLogon process, where the server cannot respond to a client request because of the autosensing problem on the adapter or switch.

RESOLUTION

To resolve this issue, manually set the media type within the driver properties of the Ethernet adapter:
  1. Open the Network tool in Control Panel.
  2. Right-click the appropriate adapter, and then click Properties.
  3. Click Configure, and then click Advanced.
  4. An entry for the media type is available, and after you determine the speed of the port on the switch that the client computer is connected to, set the media type to this speed. You must also make sure that the duplex setting of each port on the switch matches the duplex setting of the adapter. You may need to view the switch manufacturer's documentation for more details about port configuration. The media type may also be set to a slower speed to help resolve the issue. If the option to manually set the media type is not available, check to see if the manufacturer has posted updated drivers for the adapter.

Modification Type:MinorLast Reviewed:12/21/2004
Keywords:kbHardware kbnetwork kbprb KB298733