PRB: Documents Processed by BizTalk Server Appear Stuck in Work Items Queue (298728)
The information in this article applies to:
- Microsoft BizTalk Server 2000
This article was previously published under Q298728 SYMPTOMS
When you submit a document for processing by Microsoft BizTalk Server, the document may not move out of the Work Items queue, and the following informational messages may appear in the Application log of the BizTalk Server:
Event Type: Information
Event Source: MSDTC Client
Event Category: CM
Event ID: 4156
Date: 5/2/2001
Time: 1:28:38 PM
User: N/A
Computer: <ServerName>
Description:
String message: INFORMATIONAL : CSO::Maintain_SSTATE_UP session Failed ProcID=0x5c0 Error =0x80004005.
Event Type: Information
Event Source: MSDTC
Event Category: CM
Event ID: 4156
Date: 5/2/2001
Time: 1:28:47 PM
User: N/A
Computer: <ServerName>
Description:
String message: ProcId = 0x1e4 CSO: Maintain session; Received E_CM_SERVER_NOT_READY.
CAUSE
This problem can occur if the Microsoft Distributed Transaction Coordinator (MS DTC) Globally Unique Identifier (GUID) for BizTalk Server matches the MS DTC GUID on the remote Microsoft SQL Server computer that houses the BizTalk Server InterchangeBTM database.
RESOLUTION
Uninstall and reinstall the MS DTC on the BizTalk Server and the SQL Server. For additional information on how to do this, click the article number below
to view the article in the Microsoft Knowledge Base:
246679 BUG: DTC Remote Coordinator Fails After DTC Is Configured for an Invalid Remote Host Name
STATUS
This behavior is by design.
MORE INFORMATION
The MS DTC GUID for two Windows 2000 servers is always unique unless the operating systems on these computers were created with ghosting software.
Modification Type: | Major | Last Reviewed: | 10/17/2003 |
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Keywords: | kbprb KB298728 |
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