XCON: Internet Mail Connector Does Not Start and Event ID 4086 Is Logged (298565)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3

This article was previously published under Q298565
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to manually start the Microsoft Exchange Internet Mail Connector (IMC) on a Microsoft Windows NT 4.0 computer, you may receive the following error message:
Services
Could not start the Microsoft Exchange Internet Mail Connector service on \\computername.
Error 2140: An internal Windows NT error occurred.
Additionally, the following event ID message may be logged in the Application event log:

Event ID: 4086
Source: MSExchangeIMC
Type: Error
Category: Initialization/Termination
Description: Unable to start the service because the configuration could not be loaded from the Microsoft Exchange directory or Windows NT Registry.

CAUSE

This issue may occur if the value of the following registry key does not match the corresponding directory entry:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeIMC\Parameters\SiteDN

This issue may also occur if the wrong Organization or Site name was used when Exchange Server was reinstalled on the computer.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To resolve this issue, edit the value of the registry key so that it matches the corresponding directory entry, or reinstall Exchange Server using the correct Organization and Site names.

To edit the registry:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the SiteDN value under the following key in the registry:

    HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeIMC\Parameters\SiteDN

  3. Check the value for this key. Make sure that the Organization [o=] and Site [ou=] exactly match the properties of the Organization, Site, and Server objects as they are displayed in the Exchange Server Administrator program. The Server directory name [cn=] is not required. The MSExchangeIMC is not specific to the CN. To determine the names of these objects, follow these steps:
    1. Start the Administrator program.
    2. In the left pane, expand the Organization object, expand the Site object, and then expand the Server object.
    3. On the File menu, click Properties. The directory name of each of these objects must exactly match the corresponding attributes in the registry setting that is described in step three.
  4. Quit Registry Editor.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB298565 kbAudITPRO