IP Addresses Are Not Resolved When You Manually Configure DNS Servers (298537)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q298537
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you manually configure the network adapter on the server that will perform IP Resolution for your Commerce Server 2000 Data Warehouse, few if any IP Addresses are resolved to host names after you run the IP Resolution task.

CAUSE

This problem is due to the location where the DNS IP Addresses are stored. Network interfaces that are configured for Dynamic IP Address assignment store their DNS IPs in the following location: >

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

However, manually configured network interfaces do not. When the list of DNS servers is queried by the IP Resolution object, they read incorrect values for manually configured network interfaces.

WORKAROUND

To work around this problem, you can set the registry value manually or set an environment variable. However, you must remember to change this value if you decide to use an alternate DNS server to perform host name lookups.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To manually configure the registry value, locate the following value:

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\NameServer

Enter the list of DNS servers and separate them by a space. For example:

     10.1.1.1 10.1.1.2
					

RESOLUTION

To resolve this problem, obtain the latest service pack for Commerce Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

297216 INFO: How to Obtain the Latest Commerce Server 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000. This problem was first corrected in Commerce Server 2000 Service Pack 1.

Modification Type:MajorLast Reviewed:10/21/2002
Keywords:kbbetapublic kbbug kbCommServ2000PreSP1fix kbCommServ2000SP1fix kbQFE KB298537