XCON: Exchange Notes Connector Service Stops and Causes Message Backlog in the Exchange Notes Connector (298486)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3
  • Microsoft Exchange Server 5.5 SP4

This article was previously published under Q298486

SYMPTOMS

If a message that contains more than 1,024 attachments is submitted to the Exchange.box on a Lotus Notes server, the Microsoft Exchange Connector for Lotus Notes service (Lsntsmex.exe) may stop. Messages may sit in the queue and may not be delivered. The Exchange Notes Connector does not mark the message that contains more than 1,024 attachments as a problem message, but no new mail is processed until you remove the message and you restart the service.

CAUSE

This problem can occur because the Exchange Server information store cannot process more than 1,024 attachments for each message; therefore, when the connector tries to create the 1,024th (0x400th) attachment, the information store stops responding. The connector calls fail, and the Lsntsmex.exe process stops, which causes subsequent messages from Notes to Exchange Server to be backlogged.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Exchange Notes Connector

File nameVersion
Ctreestd.dll5.5.2655.24
Dispatch.exe5.5.2655.24
Dxagwise.dll5.5.2655.24
Dxamex.dll5.5.2655.24
Dxanotes.dll5.5.2655.24
Dxasnads.dll5.5.2655.24
Eab.dxa5.5.2655.24
Exconmsg.dll5.5.2655.24
Files.txt5.5.2655.24
Gw2mex.exe5.5.2655.24
Gwhc.dll5.5.2655.24
Gwrouter.exe5.5.2655.24
Lscms.dll5.5.2655.24
Lsdiajcl.exe5.5.2655.24
Lsdiamex.exe5.5.2655.24
Lsdiavm.exe5.5.2655.24
Lsdxa.exe5.5.2655.24
Lsldew.dll5.5.2655.24
Lsmexdia.exe5.5.2655.24
Lsmexhc.dll5.5.2655.24
Lsmexif.dll5.5.2655.24
Lsmexin.exe5.5.2655.24
Lsmexnts.exe5.5.2655.24
Lsntshc.dll5.5.2655.24
Lsntsmex.exe5.5.2655.24
Lsqview.dll5.5.2655.24
Lsvmdia.exe5.5.2655.24
Lsvmhc.dll5.5.2655.24
Lsxfm.dll5.5.2655.24
Mex2gw.exe5.5.2655.24
Ntsperf.dll5.5.2655.24
Ntspxgen.dll5.5.2655.24
Psab.dxa

NOTE: Because of file dependencies, this fix requires Microsoft Exchange Server version 5.5 Service Pack 4.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.

MORE INFORMATION

After this fix is applied, if there are more than 1,024 attachments, Exchange Server delivers the message with the attachments stripped out.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbExchange550preSP5fix kbfix kbQFE KB298486