XCCC: Items Unavailable on the Agents Tab When You Administer Events Scripts (298442)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q298442

SYMPTOMS

When you administer event scripts, you may be able to create scripts, but you may be unable to edit or delete them; when you open the folder's properties, and then click the Agents tab, the following symptoms may occur:
  • The Delete button is unavailable.
  • When click Edit, and then make the changes, the OK button is unavailable. You are unable to save your changes.
  • The drop-down list that describes the server that the scripts are running from is unavailable.

CAUSE

This issue can occur if the level of required permissions on the EventsConfig_servername container has been changed. In Exchange Server 5.5, at least Author permissions are required on the EventsConfig_servername container. In Exchange 2000, at least Editor permissions are required on the EventsConfig_servername container.

RESOLUTION

To resolve this issue:
  1. Start Exchange System Manager.
  2. Click to expand the the Administrative Groups container, and then click to expand the Folders container.
  3. Right-click Public Folders, and then click View System Folders.
  4. Click to expand the Events Root container.
  5. Right-click EventsConfig_servername and click Properties.
  6. Click the Permissions tab, and then click Client Permissions.
  7. Assign the role of Editor to users who administer scripts, and then click OK.
  8. Click OK.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB298442