Internet Connection Wizard Stops Responding When You Start Internet Explorer for the First Time (298096)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98

This article was previously published under Q298096
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to start Microsoft Internet Explorer for the first time in Microsoft Windows 98, Windows 98 Second Edition (SE), or Microsoft Windows Millennium Edition (Me), the Internet Connection Wizard (ICW) may initially start and then stop responding (hang).

CAUSE

This behavior can occur if there is an incorrect value in the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Internet Connection Wizard

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, follow these steps.

NOTE: After completing this process, the ICW no longer starts automatically.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit.
  3. Click My Computer in the left pane.
  4. On the Registry menu, click Export Registry File.
  5. In the Save in box, click Desktop.
  6. In the File name box, type regbakdate.

    EXAMPLE: regbak052901
  7. Click Save.
  8. Right-click the following key

    HKEY_CURRENT_USER\Software\Microsoft\Internet Connection Wizard

    point to New, and then click Binary Value.
  9. In the box that appears, type Completed, and then press ENTER.
  10. In the Value Data dialog box, type 01 00 00 00, and then click OK.
  11. Right-click ShellNext value, and then click Delete.

    The only other remaining value in the key is DesktopChanged 0x00000001.
  12. On the Registry menu, click Exit.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kbprb KB298096