OFFXP: Error Message Log File Always Contains "Info 2898: An Internal Error Has Occurred" (298029)



The information in this article applies to:

  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q298029

For a Microsoft Office 2000 version of this article, see 230879.

SYMPTOMS

When you view the setup log file for Office, you may see the following entries even though setup was successful:
Info 2898. An internal error has occurred. Contact your Information Technology department for assistance.

-or-

Info 2743. An internal error has occurred. Contact your Information Technology department for assistance.

-or-

Info 2726. An internal error has occurred. Contact your Information Technology department for assistance.

CAUSE

These errors are debug messages and can be ignored if you did not receive an error message during setup.

MORE INFORMATION

Office will create three log files during the installation process, one for Setup.exe, one for the Windows Installer (System Files Update) and one for the Windows Installer (Office Installation). The log files will be created in your Temp folder. The log files will be created in your Temp folder and will have names similar to:
   Log file for            Log file name
   --------------------------------------------
   Setup.exe               Office XP <edition> Setup(####).txt

   Windows Installer
   (System Files Update)   Office XP <edition> Setup(####)_Task(0001).txt

   Windows Installer
   (Office installation)   Office XP <edition> Setup(####)_Task(0002).txt

				
where <edition> is the edition of Office you are installing. The #### characters in the log file names will be numbers beginning with 0001, and will increment by 1 if you have run Setup multiple times. So the log file with the highest number would be the log file for the last time you ran Setup.

NOTE: You may only have a Windows Installer log file for the Office installation and not the System Files Update installation. On most versions of Windows, the System Files Update installation is not required so a log file is not created for it. In this situation, the Windows Installer log file for the Office installation will have Task(0001) appended to the log file instead of Task(0002).

The errors listed will be in the log file for the Windows Installer.

REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup: For more articles with general information about how to troubleshoot Office errors:

Modification Type:MajorLast Reviewed:8/29/2006
Keywords:kberrmsg kbprb kbsetup KB298029