Push Notification Does Not Succeed with 403 Errors in the W3SVC Log Files (297983)



The information in this article applies to:

  • Microsoft Mobile Information 2001 Server

This article was previously published under Q297983

SYMPTOMS

When you are trying to send notifications through Outlook Mobile Access, you may receive a non-delivery report (NDR) on the client that is similar to the following one:
Your message did not reach some or all of the intended recipients.

Subject: Push Message
Sent: 5/24/2001 10:58 AM
The following recipient(s) could not be reached:

IMCEADAVNP-http+3A__MMISNotify_Exchange2000EES_username_4255551212@mobileinformationserver
The message reached the recipient's e-mail system, but delivery was refused. Attempt to resend the message. If it still fails, contact your system administrator.
<MIServer.domain.com#5.2.0>
In the W3SVC log files that are located in the System32\LogFiles\W3SVC\exYYMMDD, a 403 error log that is similar to the following sample is logged:
2001-05-24 17:58:30 127.0.0.1 - 127.0.0.1 80 NOTIFY /mmisnotify/Exchange2000EES/username/4255551212 - 403 -

CAUSE

The MMISNotify virtual root that is used for Push Notification in Mobile Information Server does not support Secure Socket Layer (SSL).

RESOLUTION

Verify that SSL is disabled on the MMISNotify virtual root:
  1. In Mobile Information Server, click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. Expand ServerName, right-click Default Web Site, and then click Properties.
  3. On the Directory Security tab, click Edit under Secure Communications.
  4. Verify that the Require Secure Channel (SSL) check box is not selected, click OK, and then OK again.
  5. Expand Default Web Site, right-click the virtual root MMISNotify, and then click Properties.
  6. On the Directory Security tab, click Edit under Secure Communications.
  7. Verify that the Require Secure Channel (SSL) check box is not selected, click OK, and then OK again.
  8. Close Internet Services Manager.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The following information from the Mobile Information Server release notes is located on the Mobile Information Server CD in the X:\English\Docs\ReleaseNotes.htm file where X is the drive letter of your CD-ROM drive.

The MMISNotify virtual root on your MIS server, which is used for notifications, does not support using SSL. If you have installed a certificate and enabled SSL on your MIS server, MMISNotify will be set to use SSL. This will cause notifications to fail. Disable SSL on MMISNotify and use an alternate security method. For example, you can restrict the IP addresses that can access MMISNotify to servers that will be sending notifications.


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB297983