SYMPTOMS
When you install Microsoft Office XP, Setup may seem very
slow to update the Windows Installer, and then you receive one of the following
error messages:
Error 2336. Setup cannot create a
temporary file in folder C:\WINNT\Installer\. Verify that the folder exists in
your system and that you have sufficient permissions to update it.
Error 2755. An internal error has occurred.
(1632 <path>\PROPLUS.MSI ) Contact Microsoft Product Support Services
(PSS) for assistance.
Note In some cases, you may receive the following error message after
a long pause, instead of one of the internal error messages:
The installer is no longer responding.
When
you create a verbose log file by using a command line similar to the following
d:\setup.exe /L*V c:\verboselog.txt
and then you open the Verboselog_Task(0001).txt log file in
WordPad and search for the internal error number in the log file, you see text
similar to the following:
MSI (s) (D4:30): Note: 1: 2336 2: 5 3: C:\WINNT\Installer\
MSI (s) (D4:30): MainEngineThread is returning 1632
MSI (c) (08:C0): Note: 1: 2755 2: 1632 3: D:\PROPLUS.MSI
Error 2755. An internal error has occurred. (1632 D:\PROPLUS.MSI )
Contact Microsoft Product Support Services (PSS) for assistance.
MSI (c) (3C:60): Note: 1: 2336 2: 5 3: C:\WINNT\Installer\
Error 2336. Setup cannot create a temporary file in folder C:\WINNT\Installer\. Verify that the folder exists in your system and that you have sufficient permissions to update it.
MSI (c) (3C:60): Product: Microsoft Office XP Professional with FrontPage -- Error 2336.
Note Sometimes you find the log information in another log file with a
name similar to Verboselog_Task(0001).txt. If System Files Update runs, the
Windows Installer log for the Office Setup may be Verboselog_Task(0002).txt.
CAUSE
This problem occurs when the following conditions are all
true:
- You install Office XP on Microsoft Windows NT 4.0 or
Microsoft Windows 2000.
-and- - The WinNT folder is located on an NTFS partition.
-and- - You have a folder called Installer under the WinNT folder,
and you do not have full access permissions to the Installer folder.
Note You can also experience these symptoms if you have only Read
permissions to the WinNT folder. This condition prevents Office Setup from
creating the Installer folder.
RESOLUTION
To resolve this problem, change the permissions on the
Installer folder to
Everyone - Read (RX)
Administrators - FullControl
SYSTEM - FullControl
Note The Installer folder is located in the directory to which Windows
is installed.
To open the directory to which Windows is installed:
- Click Start, and then click
Run.
- Type %systemroot% in the
Open box, and then click OK
Note The Installer folder is a hidden, system folder. It may be
necessary to enable the viewing of hidden and system folders.
To
enable the viewing of hidden and system folders, use the following steps:
Note Because there are several versions of Microsoft Windows, the
following steps may be different on your computer. If they are, see your
product documentation to complete these steps.
- Open the directory to which Windows is
installed.
- On the Tools menu, click Folder
Options.
- On the View tab, click Show hidden
files and folders.
- Clear the Hide protected operating system files
(Recommended) check box.
- Click OK.