Active Directory Discovery Reports Are Not Populated with Data (297784)



The information in this article applies to:

  • Microsoft Operations Manager 2000

This article was previously published under Q297784

SYMPTOMS

When you try to run Active Directory Discovery reports, the fields in the reports may not be populated, and you may receive a message that no data is available.

CAUSE

This issue typically occurs because of a lack of permissions, and the cause may be that passwords extend across only one hop. Authentication works on the local computer, but access may be denied when the request comes from a remote computer.

WORKAROUND

To work around this issue, modify the security settings:
  1. In Microsoft SQL Server Enterprise Manager, click Security, click Linked Servers, and then click ADSI.
  2. Right-click ADSI, and then click Properties.
  3. Click the Security tab.
  4. Change the security settings from they will be impersonated to they will be mapped to.
  5. Enter a user account and a password that has at least User permissions in the domain you want to report on.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

To find out whether the symptoms indicate a permissions issue, use an administrator equivalent account to log on at the Reporting computer. Start the Reporting Tool, and then select an Active Directory report for generation. If the fields in the report are populated, a permissions issue is confirmed.

For more information about setting up security, refer to the following article in the Microsoft Knowledge Base:

242025 How to Set Up Security for Linked Server to OLAP


Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbbug kbenv KB297784