FIX: Site Server 3.0 Commerce Server Foundation Wizard Stops Responding When It Is Installed in an Application Center 2000 Cluster (297718)



The information in this article applies to:

  • Microsoft Application Center 2000
  • Microsoft Site Server 3.0

This article was previously published under Q297718

SYMPTOMS

The Microsoft Site Server 3.0 Commerce Server Foundation Wizard and Microsoft Internet Information Services (IIS) may stop responding (hang) when you try to create a site foundation on an Application Center 2000 Cluster Controller.

CAUSE

The Application Center 2000 Replication process (Acsrepl.exe) registers with the metabase for metabase change notification. The Site Server 3.0 Commerce Server Foundation Wizard adds values to the metabase that result in a notification in the Acsrepl.exe process. The Commerce Server Foundation Wizard waits for a response from the Acsrepl process before it continues. However, the Acsrepl process does not return promptly from the sink notification because it is blocking on an attempt to instantiate the IIS Admin Base Object.

RESOLUTION

To resolve this problem, upgrade to Application Center 2000 Service Pack (SP) 1. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

309384 INFO: How to Obtain the Latest Application Center 2000 Service Pack

To work around this problem, create all Commerce Server Sites before you install Application Center 2000.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was corrected in Application Center 2000 Service Pack 1.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB297718