ReceiveAny Thread Generates "RPC_S_OUT_OF_MEMORY" Error (297534)
The information in this article applies to:
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Server 4.0 SP1
- Microsoft Windows NT Server 4.0 SP2
- Microsoft Windows NT Server 4.0 SP3
- Microsoft Windows NT Server 4.0 SP4
- Microsoft Windows NT Server 4.0 SP5
- Microsoft Windows NT Server 4.0 SP6
- Microsoft Windows NT Server 4.0 SP6a
This article was previously published under Q297534 SYMPTOMS
When a program uses RPC for socket communication, it may stop working for no apparent reason. If you quit and start the program again, it works correctly, but may stop working again. If you check the output of the netstat -n command, Netstat reports many open connections in a CLOSE_WAIT state with the port that the program is using. This is a sample of the output from the netstat -n command:
Active Connections
Proto Local Address Foreign Address State
...
TCP 10.0.0.1:1091 10.0.0.5:1306 CLOSE_WAIT
TCP 10.0.0.1:1091 10.0.0.5:4001 CLOSE_WAIT
TCP 10.0.0.1:1091 10.0.0.5:1500 CLOSE_WAIT
...
CAUSE
This problem occurs because RPC uses a socket that is called a SyncSocket to optimize data communication. If the Syncsocket is closed incorrectly by the program that loaded the RPC transport, RPC enters an error loop that it cannot return from. RPC always assumes that the SyncSocket will always be a valid socket, and does not have any recovery mechanism to handle situations in which another function closes the SyncSocket.
RESOLUTIONA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem. To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Size File name Platform
---------------------------------------------------
05/17/2001 04:54p 37,648 Rpcltscm.dll Intel
05/17/2001 04:50p 60,176 Rpcltscm.dll Alpha
NOTE: Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.
WORKAROUND
To work around this problem, restart the program that is using RPC.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 10/19/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE KB297534 |
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