PRB: g_MSCSAdminEventLog: Errors Occur When You Load the Business Desk Application (297529)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q297529

SYMPTOMS

When you attempt to load the Commerce Server Business Desk, you may receive the following error:
Errors occurred while loading part of the Business Desk.

Technical Information (for support personnel)

  • Error Type:
    Active Server Pages (0x8002802B)
    An error occurred while creating object 'g_MSCSAdminEventLog'.
  • Browser Type:
    Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
  • Page:
    GET /retailbizdesk/Default.asp
  • Time:
    Thursday, January 11, 2001, 2:17:26 PM
NOTE: This error is specific to running the RetailBizDesk at a certain time. The "Error Type" message should be the same, but the other sections will vary based on the Business Desk that you are attempting to run, as well as the date and time.

CAUSE

The Identity account for the Commerce Event Logging application in Microsoft Transaction Server (MTS) fails to log in when the Commerce.AdminEventLog.1 component is invoked.

RESOLUTION

Reset the password for the Commerce Event Logging Microsoft COM+ application by using the Component Services application. To do this, follow these steps:
  1. Click Start, click Programs, click Administrative Tools, and then click Component Services.
  2. Click to expand Component Services, expand Computers, expand My Computer, and then expand COM+ Applications.
  3. Right-click Commerce Event Logging, and then click Properties.
  4. Click the Identity tab, and then type the password for the user account.
  5. Re-type the password in the Confirm password text box.
  6. Click OK to apply the settings.
  7. Restart IIS by running IISRESET from the command line.
  8. Browse to the Business Desk Web site.

STATUS

This behavior is by design.

MORE INFORMATION

The Commerce.AdminEventLog object is created through Microsoft Transaction Server and resides in a server application named Commerce Event Logging. The initial user name and password that this application is created under is set during the installation of Commerce Server 2000. When the password for this account changes, and the COM+ application is forced to restart, the error occurs.

REFERENCES

For additional troubleshooting information on Commerce Server 2000, see the Commerce Server online documentation.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbprb KB297529