BizTalk Messaging Manager May Timeout When You Attempt to Browse Available AICs (297520)



The information in this article applies to:

  • Microsoft BizTalk Server 2000

This article was previously published under Q297520

SYMPTOMS

When you browse the Application Integration Component (AIC) transports that are available, the BizTalk Messaging Manager may generate a server timeout or return the following error message when it attempts to bind a Port to a Primary Transport of Application Integration Component:
A list of application integration components could not be obtained. Error 0x1FB: An Exception occurred
There is no associated event logs or other indicators as to why this may have occurred.

CAUSE

The BizTalk Messaging Manager attempts to enumerate the AICs that are listed in the registry as BizTalk AIC (category IDs of CATID_BIZTALK_AIC). The Messaging Manager creates an instance of each AIC, and then retrieves its properties and releases the component. If the component fails at any time during the this process, the Messaging Manager may timeout or return an error, and fail to enumerate any AICs that are registered as a BizTalk AIC component. This failure usually occurs in the constructor or destructor of the AIC.

NOTE: This error does not occur if the AIC is properly registered as a COM+ application.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:kbprb KB297520