Share Point Portal Server and Internet Information Services Processes Take Up 100 Percent CPU (297480)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q297480

SYMPTOMS

The server is reporting 100 percent CPU usage by one of the following processes: Dllhost.exe, Mssearch.exe, or Cscript.exe. Client connections to the portal time out. You are able to end the processes, but the next time you try to access the workspace, another process takes up 100 percent CPU time. Restarting the server does not fix the problem.

CAUSE

The server is stuck in a loop and cannot update the Internet Publishing Provider cache.

RESOLUTION

Stop the World Wide Web Publishing Service (W3SVC), and then delete the Internet Publishing Provider cache. You may need to restart the server.
  1. Close all open applications on the server.
  2. Click Start, click Run, type cmd in the Open box, and then press ENTER. Leave the command prompt window open.
  3. Click Start, and then click Shut Down.
  4. Simultaneously press the CTRL+ALT+SHIFT keys. While you have all three keys pressed, click Cancel in the Shut Down Windows dialog box. All windows close except the command prompt window.
  5. In the command prompt window, change directory to the following location:

    %system drive%\Documents and Settings\All Users\Application Data\Microsoft\MSDAIPP\Offline

  6. Delete all files in this directory. Note that application data and its subfolders are hidden.
  7. Change directory to the Offline folder for the current user, located at:

    %appdata%\Microsoft\Msdaipp\Offline

    To locate the current user's appdata value, type set at the command prompt, and then look for the value of the Appdata variable. Delete all files in the Offline directory.
  8. Type explorer at the command prompt, and then press ENTER.
  9. Type net start w3svc.
  10. You may need to restart the server if the problem is not resolved.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:1/3/2003
Keywords:kbbug KB297480