XADM: Mail to Offline Address Book Users Is Returned with a Non-Delivery Report (297471)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q297471

SYMPTOMS

After a Microsoft Outlook user successfully downloads the offline Address Book from an Exchange 2000 Server computer, if the user sends mail to a user in the offline Address Book, the user may receive the following non-delivery report (NDR):
Your message did not reach some or all of the intended recipients.

Subject: Test
Sent: 4/30/01 4:52 PM

The following recipient(s) could not be reached:

/Cn=rganization/OU=Site/CN=Recipients/CN=Test on 4/30/01 4:52 PM The e-mail address could not be found. Perhaps the recipient moved to a different e-mail organization, or there was a mistake in the address. Check the address and try again.
<server.domain.com #5.1.0>

CAUSE

This issue can occur if the user's legacyExchangeDN attribute is stored in all uppercase letters in Active Directory.

RESOLUTION

To resolve this issue, use one of the following methods:
  • Contact Microsoft Product Support Services to obtain the Fbfix.zip file. This file contains the files that you need to resolve this issue programmatically. For additional information, see the Readme.txt file that is included in the Fbfix.zip file.
  • Use the ADSI Edit tool that is included with the Microsoft Windows 2000 Support Tools to change the legacyExchangeDN attribute.

    WARNING: If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Exchange 2000 Server, or both. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

    To use ADSI Edit to change the legacyExchangeDN attribute:
    1. Click Start, point to Programs, point to Windows 2000 Support Tools, and then click ADSI Edit.
    2. In ADSI Edit, locate the mailbox of the user who is experiencing this issue (the mailbox should be located under the domain tree), right-click the mailbox, and then click Properties.
    3. Click the Attributes tab, and then click either Optional or Both to view the properties of the attribute.
    4. In the Select a property to view list, click the legacyExchangeDN attribute.
    5. Copy the entire entry in the Value box, and then paste the entry in the Edit Attribute box.
    6. Change the values that follow the delimiters to lowercase letters. For example, change the following value

      /O=ORG NAME/OU=SITE NAME/CN=RECIPIENTS/CN=AD USERS/CN=USERS/CN=USER NAME

      to the following value:

      /o=ORG NAME/ou=SITE NAME/cn=RECIPIENTS/cn=AD USERS/cn=USERS/cn=USER NAME

    7. Click Set to set the changes to the legacyExchangeDN attribute.
    8. Repeat the preceding steps for the mailbox of each user who is experiencing this issue.

MORE INFORMATION

This issue can also affect public free and busy information updates. For additional information about free and busy errors that are caused by LegacyExchangeDN, click the following article number to view the article in the Microsoft Knowledge Base:

286783 Error message updating free and busy data in Exchange 2000 Server


Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB297471