You May Be Unable to Connect to the Microsoft Metadirectory Services Server by Using the XML and File Toolkit Wizard (297241)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.2 SP1

This article was previously published under Q297241

SYMPTOMS

After you install and run the Extensible Markup Language (XML) and File Toolkit for the first time, and you attempt to connect to a Microsoft Metadirectory Services server, you may receive the following error message:
The Microsoft Metadirectory Services XML and File Toolkit Wizard has detected that the Microsoft Metadirectory Services server has not installed the Microsoft Metadirectory Services XML and File Toolkit server components. Please confirm that your Microsoft Metadirectory Services server version is 2.2 or later and has the components installed.
After you verify that the Microsoft Metadirectory Services Service Pack 1 (SP1) server is installed and can be accessed by the Microsoft Metadirectory Services Compass client, you may still receive the preceding error message.

CAUSE

This problem can occur if you have a Zoomserv\Bin folder from an earlier installation installed on drive C and your valid Zoomserv folder is installed on another drive. Setup searches all fixed drives, starting with drive C, for the \Zoomserv\Bin\Viaserver.exe folder and uses the first folder that is found as the default folder.

RESOLUTION

To work around this problem, use either of the following two workarounds:
  • Rename all of the \Zoomserv folders, except for the target \Zoomserv folder so that Setup selects the correct folder.
  • Run Setup with the following text:

    'msiexec /I "MMS XML and File Toolkit.MSI" VIASERVER_PATH=d:\zoomserv\bin\viaserver.exe'

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbenv kberrmsg kbprb kbQFE KB297241