PCHealth Does Not Install on OEM Turkish-Language Version of Windows Millennium Edition (297189)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q297189

SYMPTOMS

If the computer date and time was later than 19:59:59 Tuesday, April 17, 2001 when the Turkish-language version of Windows Millennium Edition (Me) was installed, PCHealth may not install correctly.

If you by click Start (Baslat), and then click Help (Yardim) to try to gain access to Windows Help, and Help does not open, you may be experiencing the problem that this article describes.

The following error message may also be logged in the Pchealth_setup.log file:
WARNING!! Tampered Signature file C:\WINDOWS\PCHealth\Support\pchsign.cab
NOTE: The update that this article describes is applicable to original equipment manufacturer (OEM), or pre-installed, images of Windows Millennium Me. If you are experiencing the problem that this article describes on an existing OEM or retail product installation, refer to the following Microsoft Knowledge Base article:

299850 PCHealth Does Not Work on Turkish-Language Version of Windows Millennium Edition

CAUSE

This problem can occur if several cabinet files have digital signatures with certificates that are inserted in an order that makes it appear that the certificates were not time stamped, and that the certificates expired on the indicated date.

The affected files' signatures are only valid from 20:00:00 Monday, April 03, 2000 to 19:59:59 to Tuesday, April 17, 2001. The following files from the Win_9.cab file are affected:
  • Pchsign.cab (Windows Me PCHealth, Turkish only)
  • Pss.cab (Windows Me PSS, Turkish only)

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The Turkish-language version of this fix should have the following file attributes or later:
   Date        Time        Version       Size     File name
   -----------------------------------------------------------
   05/11/2001  02:06 P.M.  N/A             7,834  Pchsign.cab
   05/11/2001  02:06 P.M.  N/A            16,111  Pss.cab
   05/15/2001  04:35 P.M.  4.90.0.3004   217,360  Hcupdate.exe
   05/09/2001  10:26 A.M.  4.90.0.3004    90,384  Pchsetup.exe
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Incorporate the updated components into a pre-installation image of the operating system. Installing the update as a pre-installed application is not supported because the package does not register the catalog with the System File Protection (SFP) database. Refer to the Microsoft Windows Me OEM Pre-Installation Kit (OPK) documentation for additional information.

Reference System Manual Pre-Installation

The update that this article describes is packaged for the sake of convenience. Although this update does contain an .inf file (Qfereg.inf) that can be used to register the catalog, this .inf file is not invoked if the package is run.

Extract the files that the update contains, and then register the catalog file (Wse18067.cat, also enclosed in the update package) with SFP after Setup is finished to ensure that the updated files are signed correctly:
  1. Place the files that are listed in the "Resolution" section of this article in the folder that contains the Windows Me cabinet files, and then run Setup.
  2. After Setup is finished, copy Wse18067.cat to the %WinDir%\Inf\Catalog folder, and then run the following command (you can do so with a RUNONCE or RUNONCESETUP registry key):

    %windir%\system\sucatreg /D:WSE18067.cat

Extracting Files from the Update Package

To obtain the files that the update contains, you can extract the contents of the update to a folder, as shown in the following command example:

297189TRKM.EXE /c /t:destination_folder

For additional information about how to determine which folder Windows is installed in, click the article number below to view the article in the Microsoft Knowledge Base:

305792 How to Determine Which Folder Windows Is Installed In

For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

295413 General Information About Windows Millennium Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbbug kbenv kbfix kbQFE kbsetup KB297189