XCCC: Instant Messaging Setup Does Not Work When It Cannot Find Internet Explorer Files (297106)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q297106 SYMPTOMS
When you install Instant Messaging, you may encounter an error message that states that Setup cannot continue because Microsoft Internet Explorer is not installed.
CAUSE
This error is generated during Instant Messaging Setup when Internet Explorer has been installed on a different physical or logical drive than the operating system. When you install Internet Explorer in a different location, the dependency files that Instant Messaging Setup references in the registry are missing, which causes the error to be generated.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
WORKAROUND
To work around this issue, check the following key in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\
This key points the Instant Messaging installer to the location for the four Internet Explorer dependency files: Msxml.dll, Digest.dll, Ws2_32.dll, and Snmpapi.dll. If the path is different than %SystemRoot%\System32, copy the dependency .dll files listed in the key to the folder that is indicated in the registry key.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
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Keywords: | kbbug kbfix KB297106 |
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