The Performance Counters for the Exchange Event Source Do Not Increment from a Remote Connection (297090)



The information in this article applies to:

  • Microsoft Mobile Information 2001 Server

This article was previously published under Q297090

SYMPTOMS

After you have set up the Mobile Information Server Exchange Event Source on Microsoft Exchange 2000 Server, the Performance Monitor counters that are specific to the Exchange Event Source may not report any activity when they are viewed from a remote Performance Monitor (Perfmon.exe) connection.

Even if push messages are sent correctly by means of the Exchange Event Source, the counters, such as, Events Triggered or Total notifications sent, do not increment (they remain at zero [0]).

CAUSE

This problem can occur because the remote Performance Monitor counters work with Microsoft Remote Registry service (Regsvc.exe). For the new counters to register with this service, the service has to be restarted.

Performance Monitor counters can read correctly on the console of the server, but a remote Performance Monitor (by means of the Performance Monitor Microsoft Management Console [MMC] from another workstation) displays all of the counters at zero (0).

WORKAROUND

To work around this problem, restart the Microsoft Remote Registry service on the Exchange Event Source server (Exchange 2000 Server). This restart can cause the newly added counters to register with the Microsoft Remote Registry service when it starts up.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

In some situations, the objects for the Store sink are not displayed in the list of available objects when the computer is connected remotely. You can fix this problem by cycling the Microsoft Remote Registry service.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB297090