Incomplete HTML Pages and Random Authentication Prompts If ISA Server Is Chained to Upstream Proxy (297080)
The information in this article applies to:
- Microsoft Internet Security and Acceleration Server 2000
This article was previously published under Q297080 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
If Internet Security and Acceleration (ISA) Server 2000 is chained to an upstream Web proxy server, you may receive incomplete HTML pages and random authentication prompts in the Web browser.
These symptoms may occur if the downstream ISA Server computer is configured to require integrated authentication and if the upstream Web proxy server is also configured to require proxy authentication. In addition, the Routing rule on the downstream ISA Server computer is configured to provide Basic Authentication credentials to the upstream Web proxy server.
This behavior does not occur if the downstream ISA Server computer is not configured to provide any credentials or if it is configured to provide Integrated Authentication credentials to the upstream Web proxy server.
CAUSE
Under certain circumstances, Web browsers may try to authenticate a connection with the downstream ISA Server computer that has already been authenticated by using integrated authentication. This may cause the downstream ISA Server computer to pass those credentials to the upstream Web proxy server. Because the credentials are for the downstream ISA Server computer and not for the upstream Web proxy server, the server returns a "407 Proxy authentication required" HTTP response. The downstream ISA Server computer then passes this HTTP response back to the Web browser, causing the authentication prompt on the client computer. Because the client is unable to authenticate this request, it may cause incomplete HTML pages on the Web browser client.
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Product Name service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name
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5/6/2001 02:03PM 3.0.1200.64 373,520 W3proxy.exe
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbenv kbISAServ2000sp1fix kbprb KB297080 |
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