OLEXP: "Cannot Find Incredimail.exe" Error Message When You Open Attachment After Removing Incredimail (297069)



The information in this article applies to:

  • Microsoft Outlook Express 5.5 for Windows Millennium Edition

This article was previously published under Q297069
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you install and then remove Incredimail.exe, when you attempt to open e-mail attachments in Outlook Express version 5.5, the following error message appears:
Windows cannot find Incredimail.exe

CAUSE

This behavior can occur if registry keys for Incredimail remain in the Windows registry after you remove the Incredimail program from the system.

RESOLUTION

To resolve this behavior, remove Outlook Express 5.5, delete the remaining Incredimail references from the registry, and then reinstall Outlook Express 5.5.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To delete the registry keys for the Incredimail program:
  1. Start Registry Editor (Regedt32.exe).
  2. For each key that you need to delete, locate the key, right-click the key, and then click Delete:
    1. Under the HKEY_CLASSES_ROOT key, delete the following keys:

      \.ima

      \.imf

      \.imi

      \.imn

      \.ims

      \.imw

      \Applications\Impcontent.exe

      \Applications\Incredimail

      \Incredicontent

      \Incredimessage

    2. Under the HKEY_LOCAL_MACHINE key, delete the following keys:

      Software\Classes\.imc

      Software\Clients\Mail\Incredimail

      Software\Elishim\Protect\Browser (remove the Incredimail value)

      Software\Incredimail

      Software\Microsoft\Direct3D\Most Recent Applications\ (remove the NAME value that points to Incredimail.exe)

      \Microsoft\Windows\CurrentVersion\App Paths\Incredimail

    3. Delete the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu\Programs\Incredimail key.
  3. Quit Registry Editor.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For additional information about how to remove and then reinstall Outlook Express, click the article number below to view the article in the Microsoft Knowledge Base:

Q278909 How to Manually Uninstall and Reinstall OLEXP on Win Me


Additional information about Incredimail is available at the following Incredimail Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:7/13/2004
Keywords:kb3rdparty kbprb KB297069