FP: Error Message: Cannot Access the Access.ldb or the Lock File (297012)
The information in this article applies to:
- Microsoft FrontPage 98 for Windows, when used with:
- Microsoft Windows NT Server 4.0
This article was previously published under Q297012 SYMPTOMS
When you attempt to connect to a Microsoft Access database by using a Microsoft Active Server Pages (ASP) page created in Microsoft FrontPage, you may be unable to do so.
When you submit an action or a query, the server "times out" while attempting to connect to the database, and then you may receive the following error message:
Cannot access the access.ldb or the lock file.
CAUSE
This behavior can occur if the Microsoft Windows NT INTERACTIVE and NETWORK system accounts do not have sufficient security permissions to gain access to the Access database file (.mdb).
RESOLUTION
To resolve this issue, edit the security permissions of the database file to add the Windows NT NETWORK and INTERACTIVE system accounts, thereby granting these accounts Change permissions to the file. To do this, follow these steps:
- In Microsoft Windows Explorer, locate the Access database file that you want.
- Right-click the file, and then click Properties on the shortcut menu that appears.
- In the file name Properties dialog box, click Permissions on the Security tab.
- In the File Permissions dialog box, click Add.
- In the Add Users and Groups dialog box, click INTERACTIVE in the Names list, click Add, click NETWORK, and then click Add.
- In the Type of Access list, click Change, and then click OK.
- In the File Permissions dialog box, click OK, and then click OK in the file name Properties dialog box.
Modification Type: | Minor | Last Reviewed: | 6/16/2006 |
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Keywords: | kberrmsg kbprb KB297012 |
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