Remote Clients Cannot Print on Shared Printer That Uses Intel Network Port (296979)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q296979

SYMPTOMS

After you create a shared printer on a computer that uses the Intel Network Port, remote clients may not be able to print on the shared printer.

CAUSE

This behavior can occur because the spooler IsLocalCall function, which detects whether a call originates from the local computer or from a remote computer, does not work correctly with Intel Network Port.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

WORKAROUND

To work around this behavior, print a test page from the print server that uses the Intel Network Port. Clients should then be able to print to that print server until the print server is restarted.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows 2000. This problem was first corrected in Windows 2000 Service Pack 2.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For information about how to contact Intel Corporation, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:11/19/2003
Keywords:kb3rdparty kbbug kbfix kbHardware kbnetwork kbprint KB296979