Ldifde.exe Returns an Error Message with "<" Character During Import (296656)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Professional SP1
This article was previously published under Q296656 SYMPTOMS
When you import data to Active Directory by using the Ldifde utility, the process may not work and may generate the following error message:
There is a syntax error in the input file
Failed on token starting with ... on line ...
0 entries modified successfully.
An error has occurred in the program
The second line in the error message contains data about the line in the input file in which the error occurred. That information was removed from this sample error message.
CAUSE
When the data was originally exported, certain characters did not trigger Base64 encoding of the string. The fix that is documented in this article corrects support for data that begins with characters that are defined in the Request for Comments (RFC) specification, including the space, colon, or "<" and ">" characters.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
WORKAROUND
You can use the CSV Directory Exchange Tool (Csvde.exe), which is a close relative to Ldifde.exe, without the same restriction. Csvde.exe uses comma-separated value files.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.
Modification Type: | Major | Last Reviewed: | 11/14/2003 |
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Keywords: | kbbug kbDirServices kbfix kbWin2000sp3fix KB296656 |
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