You cannot connect to MSDE or SQL Server 7 desktop edition in Access 2002 (296444)



The information in this article applies to:

  • Microsoft Access 2002, when used with:
    • the operating system: Microsoft Windows 98

This article was previously published under Q296444
Moderate: Requires basic macro, coding, and interoperability skills.

For a Microsoft Access 2000 version of this article, see 198977.

SYMPTOMS

You receive one of the following error messages when you try to connect to either the Microsoft Data Engine (MSDE) or Microsoft SQL Server 7 Desktop Edition on a computer running Microsoft Windows 98:
Test Connection Failed because of an error initializing the provider [DBNMPNTW] Specified SQL Server not found

-or-

Server: Msg 6, Level 16, State [Microsoft][ODBC SQL Server Driver][Named Pipes]Specified SQL Server Not Found

CAUSE

Computers that are running Windows 98 cannot accept incoming Named Pipes connections. If you install MSDE or Microsoft SQL Server 7 Desktop Edition on one of these computers, clients trying to connect to the server must use an alternate net library.

RESOLUTION

On each client that you intend to use to connect to MSDE or SQL Server 7 Desktop Edition running Windows 98, use the Client Network Utility to create an alias. Creating an alias allows you to specify which network library to use when you connect to a specific server.

Follow these steps on each client:
  1. Click Start, and then click Run.
  2. In the Open box, type cliconfg.exe, and then press ENTER.
  3. On the General tab of the SQL Server Client Network Utility, click Add.
  4. In the Server Alias box, enter the name of the server that you want to connect to.
  5. In the Network Libraries Option Group, click TCP/IP.
  6. Click OK.
  7. On the General tab of the SQL Server Client Network Utility, click Apply, and then click OK.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Install the Microsoft Data Engine (MSDE) on a computer that is running Windows 98.
  2. On a second computer, install Microsoft Office XP. This is your client computer.
  3. On the client computer, click Start, point to Settings, and then click Control Panel.
  4. In Control Panel, open the ODBC Data Sources (32bit) tool.
  5. On the System DSN tab, click Add.
  6. Click SQL Server, and then click Finish.
  7. On the next page, type the data source name and also the name of the computer on which you installed MSDE. A description is optional.
  8. Click Next.
  9. Enter the login information that is needed to connect to the server. If you have not changed the default settings on the server, select SQL Server Authentication with a Login ID of sa and no password.
  10. Click Next.

    Note that you receive one of the errors that is mentioned in the "Symptoms" section of this article.

Modification Type:MinorLast Reviewed:8/12/2004
Keywords:kberrmsg kbprb KB296444