XADM: Setup Cannot Register the Exoledb.dll File (296436)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q296436 SYMPTOMS
During the Exchange 2000 setup or upgrade process, Setup may stop, and an error regarding the registering of Exoledb.dll is displayed. In the Exchange 2000 Setup log, you may receive one of the following error messages:
The command
failed, returning error code 5 (Access is denied).
Setup failed with 0xc103798a registering the base dav protocol.
CAUSE
This error may occur if the .dll files, upon which the Exoledb.dll file is dependent, are not registered.
WORKAROUND
To work around this error, manually register the dependent .dll files (Msdaurl.dll, Msdaipp.dll, and Oledb32.dll) by typing the following command from a command prompt where name.dll is the name of the .dll file that you want to register:
For example, to register the Msdaurl.dll file, type the following command from a command prompt:
Generally, the Msdaurl.dll, Msdaipp.dll and Oledb32.dll files are located in the %SystemRoot%\Program Files\Common Files\System\Ole DB folder. You need to run the regsvr32 command in the directory in which the .dll files are located.
After you register these files, you can click Retry in the Setup dialog box to allow Exchange Setup to register the Exoledb.dll and continue with Setup.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
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Keywords: | kbprb KB296436 |
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