Cannot Use Regtrace to Troubleshoot Permission Issues in the Business Desk (296330)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q296330

SYMPTOMS

In Microsoft Commerce Server 2000, Business Desk components that use BDSecurity.dll for permissions access do not log unique errors. Also, the Regtrace tool cannot be used to troubleshoot permission issues in the Business Desk.

CAUSE

The BDSecurity object does not implement Regtrace in Commerce Server 2000.

RESOLUTION

To resolve this problem, obtain the latest service pack for Commerce Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

297216 INFO: How to Obtain the Latest Commerce Server 2000 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000. This problem was first corrected in Commerce Server 2000 Service Pack 1.

MORE INFORMATION

The BDSecurity.dll file uses the CanUserAccess method to determine if the user has access rights to a Business Desk module. If there are errors in the underlying Windows 2000 API, these errors are rolled up into one and the Business Desk returns an UnableToLoadBizdeskXML error. With the additional implementation of Regtrace in the object for Commerce Server 2000 Service Pack 1, you can use Regtrace to troubleshoot Business Desk issues.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbCommServ2000PreSP1fix kbCommServ2000SP1fix kbfix KB296330