Error 0x80040E37 Returned When You Run an ADO Query Against Active Directory Over SSL (296254)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2

This article was previously published under Q296254

SYMPTOMS

When you are using the ADSDSOObject ADO provider to query the Active Directory by using LDAP over SSL, you may receive the following error message:
0x80040E37 Table does not exist.

CAUSE

This issue can occur if the client that initiates the SSL connection did not validate the domain controller's certificate. The most likely cause of this error is that the client does not trust the certificate that is presented by the domain controller because the root CA that issued the domain controller certificate is not trusted by the client.

RESOLUTION

To resolve this issue, on the client, install the root CA certificate into the local machine Trusted Root Store:
  1. Download the root CA certificate to the client.
  2. Double-click the root CA certificate.
  3. Click Install Certificate to start the Certificate Import Wizard.
  4. Click Next.
  5. Click Place all certificates in the following store, and then click Browse.
  6. Click to select the Show physical stores check box.
  7. Expand Trusted Root Certification Authorities, and then select Local Computer.
  8. Click OK.
  9. Click Next, and then click Finish. The root CA certificate has now been installed.

Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbenv kberrmsg kbprb KB296254