Indexing Stops Working and ESE98 Event Messages Are Logged (296220)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q296220

SYMPTOMS

Indexing stops working and some or all of the following error messages are logged in the Application event log on a SharePoint Portal Server computer:

Event Type: Error
Event Source: ESE98
Event Category: General
Event ID: 490
Description: mssearch (1492) An attempt to open the file "D:\Program Files\SharePoint Portal Server\Data\Ftdata\SharePointPortalServer\MSStmp.log" for read / write access failed with system error 32 (0x00000020): "The process cannot access the file because it is being used by another process". The open file operation will fail with error -1032 (0xfffffbf8).

-and-

Event Type: Error
Event Source: ESE98
Event Category: General
Event ID: 488
Description: mssearch (1492) An attempt to create the file "D:\Program Files\SharePoint Portal Server\Data\Ftdata\SharePointPortalServer\MSStmp.log" failed with system error 5 (0x00000005): "Access is denied". The create file operation will fail with error -1032 (0xfffffbf8).

-and-

Event Type: Error
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 413
Description: mssearch (1492) Unable to create a new log file because the database cannot write to the log drive. The drive may be read-only, out of disk space, misconfigured, or corrupted. Error -1032.

-and-

Event Type: Error
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 492
Description: mssearch (1492) The log file sequence in "D:\Program Files\SharePoint Portal Server\Data\Ftdata\SharePointPortalServer\" has been halted due to a fatal error. No further updates are possible for the databases that use this log file sequence. Please correct the problem and restart or restore from backup.

-and-

Event Type: Error
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 471
Description: mssearch (1492) Unable to rollback operation #128145954 on database D:\Program Files\SharePoint Portal Server\Data\Ftdata\SharePointPortalServer\sps.edb. Error: -510. All future database updates will be rejected.

CAUSE

This issue can occur if a backup program has locked the JET data and log files in the SharePoint Portal Server Ftdata folder. When you back up and restore a SharePoint Portal Server computer, only the MSDMBACK.VBS script that is shipped with the product, or a third-party backup solution that is specifically certified to work with SharePoint Portal Server is supported. If you use any other backup program, including Microsoft Windows 2000 Backup, you may receive the error messages that are described in the "Summary" section of this article.

RESOLUTION

To resolve this issue, quit the backup process and restart the Microsoft Search (Mssearch.exe) service on the server.

MORE INFORMATION

To prevent this issue from recurring, ensure that the SharePoint Portal Server Ftdata folder that is referenced in the event log error messages is excluded in the unsupported backup program on the server. This folder typically resides on the drive that you installed the data files to during Setup (this folder is located in Data\Ftdata\SharePointPortalServer). Because the data files may have been moved after installation, verify that the Sps.edb and associated files reside in the path that is referenced in the event log errors.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbprb KB296220