Missing Bookmarks When You Log On As a Member of the Directory Administrators List (295930)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.2

This article was previously published under Q295930

SYMPTOMS

After you add members to the Directory Administrators list, and then you log on to Compass as a user that is a member of that list, only the Home bookmark appears. The members of the list have the appropriate access to read and modify objects and attributes, but the following bookmarks are missing from the administrator's standard profile:
  • Applications
  • Management Agents
  • Replication Agreements
Because of the absence of the bookmarks, it may seem that the users do not have administrative access to the Microsoft Metadirectory Services (MMS) server; however, this is not the case, the users do have administrative access.

CAUSE

This behavior is a limitation of the Compass client.

RESOLUTION

To work around this behavior:
  1. Add the applications bookmarks:
    1. In Compass, log on to MMS as a member of the Directory Administrators group.
    2. Locate the Application Organization Unit (OU). This may be called something else, but this is the OU that you created when you initially installed MMS; it holds the DSA object.
    3. Right-click the object, and then click Copy.
    4. On the Actions menu, click Bookmarks.
    5. Right-click the bookmarks area, and then click Paste.
  2. Add the DSAObject bookmark (where DSAObject is the name of the server object):
    1. In Compass, log on to MMS as a member of the Directory Administrators group.
    2. Locate DSAObject, which is represented by a server icon.
    3. Right-click the object, and then click Copy.
    4. On the Actions menu, click Bookmarks.
    5. Right-click the bookmarks area, and then click Paste.
    6. This bookmark will have the name of your MMS server by default. To rename the bookmark:
      • Right-click the servername bookmark, and then click Rename.
      • Type the new name (such as Management Agents) in the Bookmark Description box. You can also type bookmark help text in the Bookmark Help Text box.
  3. Add the replication agreements bookmark:
    1. In Compass, log on to MMS as a member of the Directory Administrators group.
    2. Locate the Replication Agreements object. This object has a management agent icon, and is located under DSAObject.
    3. Right-click the object, and then click Copy.
    4. On the Actions menu, click Bookmarks.
    5. Right-click the bookmarks area, and then click Paste.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbnetwork kbprb KB295930