The Agent Manager Discovery Process May Perform Poorly (295839)



The information in this article applies to:

  • Microsoft Operations Manager 2000

This article was previously published under Q295839

SYMPTOMS

When you start the process that attempts to discover the computers that Microsoft Operations Manager 2000 (MOM) has to monitor, the Agent Manager starts, and then determines what domains are listed in the Managed Computer Rules section. (You can locate this section if you click Configuration, and then click the Agent Manager node in the MOM Administrator Console.) Then, the Agent Manager queries Active Directory (or the Microsoft Windows NT version 4.0 primary domain controller [PDC]) to enumerate the computers in the domain. However, you may observe that this query performs poorly as it undertakes the enumeration process, especially if there are multiple domains that are listed.

CAUSE

This problem can occur because the query that is run is single threaded.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

By default, the Agent Manager performs a managed computer scan every day at 2:05 A.M. You can configure both the time of the scan and the frequency of the scan: Click the Agent Manager node, and then click Properties. Then, if you want, you can change the default scan to occur less frequently.

Modification Type:MinorLast Reviewed:1/15/2006
Keywords:kbbug kbenv kbnetwork kbnofix KB295839