You may receive an "A problem occurred while Microsoft Access was communicating with the OLE Server" error message when you try to embed or link a Word document in Access (295824)



The information in this article applies to:

  • Microsoft Access 97
  • Microsoft Access 2000
  • Microsoft Access 2002
  • Microsoft Office Access 2003

This article was previously published under Q295824
Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.
Novice: Requires knowledge of the user interface on single-user computers.

This article applies only to a Microsoft Access database (.mdb).

SYMPTOMS

When you try to link or to embed a Microsoft Word document in Microsoft Access, you may receive an error message that is similar to the following error message:
A problem occurred while Microsoft Access was communicating with the OLE server. Try one or more of the following:
  1. Make sure you're connected to the network server where the OLE server application is located.
  2. Close the OLE server and restart it out of Microsoft Access.
  3. Reinstall the OLE server to ensure that its registered.



CAUSE

This problem may occur if you have Norton AntiVirus 2000, Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003, or Norton AntiVirus 2004 installed on your computer. This problem may also occur if you have run Norton's LiveUpdate and have installed the Script Blocking update for Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003, or Norton AntiVirus 2004.

RESOLUTION

Important These steps may increase your security risk. These steps may also make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We recommend the process that this article describes to enable programs to operate as they are designed to, or to implement specific program capabilities. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this process in your particular environment. If you choose to implement this process, take any appropriate additional steps to help protect your system. We recommend that you use this process only if you really require this process. For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:

129972 Computer viruses: description, prevention, and recovery


To resolve this problem, use one of the following methods.

Method 1

Turn off Norton AntiVirus Script Blocking

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

Note An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled.

Note Norton AntiVirus 2000 does not support the Script Blocking feature. If you are using Norton AntiVirus 2000, see Method 2.

For Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003, or Norton AntiVirus 2004, follow these steps:
  1. Start Norton AntiVirus.
  2. Click Options.
  3. Click Norton AntiVirus if a menu appears when you click Options.

    The Norton AntiVirus Options dialog box appears.
  4. Click Script Blocking.
  5. Click to clear the Enable Script Blocking (recommended) check box.
  6. Click OK.
Note You can turn on Script Blocking again after you are finished using Access.

For additional information, see your Norton product documentation, or visit the following Symantec Web site: If this link does not work, visit the Knowledge Base for Symantec at the following Symantec Web site, and then search for Document ID 2001041119095106:

Method 2

Turn off the Norton AntiVirus Office plug-in for Microsoft Office

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

Note
An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled.

Note This method turns off the virus scanning plug-in that is installed during Norton AntiVirus installation. This plug-in scans documents for macro virus infections in Office programs. When this plug-in is turned off, Norton AntiVirus does not scan documents that are open. However, the Norton AntiVirus Auto-Protect feature still provides on-going enhanced protection by scanning any file that you run, download, open, create, or delete. For additional information about Norton AntiVirus, see your product documentation.

For Norton AntiVirus 2002, Norton AntiVirus 2003, and Norton AntiVirus 2004, follow these steps:
  1. Start Norton AntiVirus.

    Note If Norton AntiVirus is part of Norton SystemWorks (NSW) or Norton Internet Security (NIS), start NSW or NIS, and then click Norton AntiVirus.
  2. Click Options, and then click Miscellaneous.
  3. In the How to keep Microsoft Office documents protected section, click the Enable Office plug-in.

    This clears the Enable Office plug-in.
  4. Click OK, and then quit Norton Antivirus.
For Norton AntiVirus 2001, follow these steps:
  1. Start Norton AntiVirus 2001.

    Note If Norton AntiVirus is part of Norton SystemWorks (NSW) or Norton Internet Security (NIS), start NSW or NIS, and then click Norton AntiVirus.
  2. Click Options, and then click General.
  3. In the Microsoft Office 2000 plug-in section, click the Enable plug-in.

    This clears the Enable plug-in.
  4. Click OK, and then quit Norton Antivirus.
For Norton AntiVirus 2000, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type one of the following commands, and then press ENTER.

    The command that you type depends on your operating system and the software that you are running. Make sure to include the quotation marks when you type the commands.
    • For Windows 95 or Windows 98 with Norton AntiVirus installed, type the following command:
       "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton AntiVirus\OfficeAV.dll"
    • For Windows 95 or Windows 98 with SystemWorks installed, type the following command:
       "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton SystemWorks\Norton AntiVirus\OfficeAV.dll"
    • For Windows NT or Windows 2000 with Norton AntiVirus installed, type the following command:
       "C:\Winnt\System32\Regsvr32" -U "C:\Program Files\Navnt\OfficeAV.dll"
If the command is successful, you receive the following message:

DllUnregisterServer in C:\Program Files\Norton AntiVirus\OfficeAV.dll succeeded.

If the command is not successful, search your hard disk for the OfficeAV.dll file. The path of the OfficeAV.dll file on your computer may be different from the path in the message. When you locate the OfficeAV.dll file, remember the location of the OfficeAV.dll file, and then follow these steps again. However, this time change the "C:\Program Files\Norton AntiVirus\OfficeAV.dll" part of the command in step 2 to the path of the OfficeAV.dll file on your computer.

For additional information, see your Norton product documentation, or visit the following Symantec Web site:

If this link does not work, visit the Knowledge Base for Symantec at the following Symantec Web site, and then search for Document ID 1999091612160606:

Method 3

Reinstall Norton Antivirus

For all versions of Norton AntiVirus, follow these steps:
  1. Remove Norton AntiVirus, and then restart your computer.
  2. Start Word.
  3. On the Help menu, click Detect and Repair.
  4. Reinstall Norton AntiVirus, and then restart your computer.

MORE INFORMATION

Steps to reproduce the problem

  1. Install Norton AntiVirus 2000.
  2. Create a new Access 2000 database.
  3. Create the following table, and then save the table as Table1:
       Table: Table1
       ----------------------------
       Field Name: ID
       Data Type: AutoNumber
       Indexed: Yes (No Duplicates)
    
       Field Name: Test
       Data Type: OLE Object
    
       Table Properties: Table1
       ------------------------
       PrimaryKey: ID
    					
  4. Create a form that is based on the Table1 table. Save this form as OLETest.
  5. Open the OLETest form in Form view.
  6. Right-click the Test field, and then click Insert Object.
  7. In the Insert Object dialog box, click Create from File.
  8. Type the path of a Word document, or click Browse to select a Word document.
  9. In the Insert Object dialog box, click OK to close the dialog box.

    You receive one of the error messages that is mentioned in the "Symptoms" section.

REFERENCES

For additional information about the Norton AntiVirus Office plug-in, click the following article number to view the article in the Microsoft Knowledge Base:

329820 How to use Office programs with the Norton AntiVirus Office plug-in

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
For information about how to contact Symantec Corporation, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:3/8/2005
Keywords:kberrmsg kbprb KB295824 kbAudDeveloper