The "No Disk In Drive" Message Window Does Not Close (295782)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q295782

SYMPTOMS

When you insert a program CD-ROM into a CD-ROM drive, either start Setup or enable the auto-play option for the program, and then you remove the CD-ROM from the CD-ROM drive while Setup is accessing data, you receive a "No disk in drive" message window that requests you to reinsert the CD-ROM into the CD-ROM drive.

The message window contains Cancel, Try Again, and Continue buttons, as well as a Close Window button in the upper right corner. However, regardless of the button you click, the message window remains open.

CAUSE

This behavior can occur because the display of the message window is triggered by either the file system or the input/output (I/O) manager, which queues an asynchronous procedure call (APC) to the requesting thread. If the program continues to attempt to access the missing volume, the message window is displayed.

RESOLUTION

To work around this behavior, reinsert the CD-ROM that you had previously removed. The message window closes.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:1/15/2006
Keywords:kberrmsg kbprb kbsetup KB295782