SMS: Logon Discovery Agent Creates Multiple Connections When it Passes DDRs to Site Servers (295441)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q295441 SYMPTOMS
The Windows NT Logon Discovery Agent service that is running on domain controllers may report errors when the service tries to copy Discovery Data Records (DDRs) to Systems Management Server (SMS) site servers. The following error message may be recorded hundreds of times in the Logon Discovery Agent log file (Ntlgdsca.log) that is located on the domain controller:
AddConnection to \\SMSServer\SMS_site code success
AddConnection to \\SMSServer\SMS_site code success
AddConnection to \\SMSServer\SMS_site code success
AddConnection to \\SMSServer\SMS_site code success
AddConnection to \\SMSServer\SMS_site code success
~Site site code: CopyFile E:\SMSLOGON\DDR.box\HNWADAEG.DDR to \\SMSServer\SMS_site code\inboxes\ddm.box\HNWADAEG.DDR success
CancelConnection failed ret=2250, LastError=2250
CancelConnection failed ret=2250, LastError=2250
CancelConnection failed ret=2250, LastError=2250
CancelConnection failed ret=2250, LastError=2250
The preceding entries are typical entries when this problem occurs. For example, there are five successful connections to the site server, four attempts to delete the connections that fail, although the first one succeeds.
The Logon Discovery Agent may create hundreds of connections to the SMS site server when it tries to send up the DDRs.
Over time, the number of connections that are made from the domain controller to the SMS site server may increase, and available memory on the domain controller may run out.
CAUSE
Logon Discovery Agent leaks memory (memory usage:Private Bytes) when it re-reads the site list from its configuration file (which happens at every DDR copy pass).
RESOLUTIONService Pack Information To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base: 288239How to Obtain the Latest Systems Management Server 2.0 Service Pack Hotfix InformationA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
------------------------------------------------------------------
01-Mar-00 11:10 2.0.1493.3190 965,728 Baseobj.dll Intel
01-Mar-00 11:10 2.0.1493.3190 37,728 Ntlgdsca.exe Intel
01-Mar-00 11:10 2.0.1493.3190 1,514,768 Baseobj.dll Alpha
01-Mar-00 11:10 2.0.1493.3190 58,640 Ntlgdsca.exe Alpha
NOTE: Due to file dependencies, the most recent hotfix or feature that contains the above files may also contain additional files.
WORKAROUND
To work around this problem:
- Disable the Windows NT Logon Discovery method to remove the Logon Discovery Agent service from domain controllers.
- Restart the Logon Discovery Agent service regularly on the domain controllers, for example, as part of a scheduled backup job.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.
Modification Type: | Minor | Last Reviewed: | 4/14/2006 |
---|
Keywords: | kbQFE kbHotfixServer kbSMS200preSP5fix kbDiscovery kbBug kbenv kbfix KB295441 |
---|
|