Upgrade detection fails when you upgrade to Office XP (295346)



The information in this article applies to:

  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Outlook 2002

This article was previously published under Q295346

SYMPTOMS

When you try to install the upgrade version of any of the products listed in the "Applies to" section, you may receive the following error message:
Setup failed to locate a valid qualifying product on your machine.
Please select the drive where a qualifying product can be found.
If you can select the drive letter (for example, C:) that represents where the valid qualifying product is installed and then click OK, you receive the following error message:
Error 1608. Setup was unable to locate a qualifying product.
Installation ended prematurely because of an error.

CAUSE

This error may occur when you are installing an upgrade version of the products listed in the "Applies to" section and any one of the following conditions are true:
  • Microsoft Office 97 Small Business Edition is installed.
  • Office 2000 CD2 is installed on your computer, but Office 2000 CD1 is not installed on your computer.
  • Office 2000 Small Business is not installed and you insert the Office 2000 Small Business CD1 when prompted for a qualifying product.
  • The qualifying product is located on a mapped network drive and the Product Compliance Check dialog box only lists local drives.
  • Microsoft Office 97 is installed in a folder other than the default installation folder, C:\Program Files\Microsoft Office.
  • Microsoft Office XP Small Business Edition is installed.

RESOLUTION

There are two methods to resolve this issue depending upon your upgrade circumstances.

Method 1: Use CD-ROM

This method resolves the first four conditions as listed in the Cause.

Follow these steps:
  1. Run the Setup program for Office XP.
  2. Type the product key in the User Information dialog box, and then click OK.
  3. In the Product Compliance Check dialog box, click your CD-ROM drive in the Drive list.
  4. Eject the Office XP CD, and then insert CD1 from Office 2000 or Office 97. If you are using Office 2000 Small Business Edition, insert CD2.
  5. Wait 30 seconds to allow the CD-ROM drive to spin up and recognize the new CD that you inserted.
  6. Click OK in the Product Compliance Check dialog box.
  7. When the Office XP End-User License Agreement appears, eject the previous version CD, and then insert your Office XP CD.

    Note If you do not eject your Office 2000 or Office 97 CD at this point, you receive an error message after the Office XP installation continues.
    Error 25003
    For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

    300852 OFFXP: Error 25003 When You Run Setup for Upgrade Installation

  8. Accept the Office XP End-User License Agreement, and then click Next.
  9. Complete the installation for Office XP.

Method 2: Select Drive Letter

This method resolves the error when Microsoft Office 97 does not reside in the default installation folder.

Follow these steps:
  1. Run Setup for Office XP.
  2. Type the product key in the User Information dialog box, and then click OK.
  3. In the Product Compliance Check dialog box, click the Drive list.
  4. Select the drive letter where Office 97 is installed.
  5. Click OK in the Product Compliance Check dialog box.
  6. Accept the Office XP End-User License Agreement, and then click Next.
  7. Complete the installation for Office XP.

MORE INFORMATION

Microsoft Office XP is available as a non-upgrade version (full version) and as an upgrade version. The upgrade version requires that a qualifying product is installed on your computer or that the installation media from the qualifying product is available when you run the Setup program. The setup program for the upgrade version of Office XP attempts to detect qualifying software on the computer on which it is running. If the setup program is unable to detect a qualifying program on the computer (such as Office 97 or Office 2000), an error occurs.

If you do not have a valid qualifying product, return the Office XP Upgrade product, and purchase a full retail version of the Office XP product. For additional information about the list of qualifying products for the Office XP Upgrade, click the article number below to view the article in the Microsoft Knowledge Base:

290540 OFFXP: Products That Qualify for the Microsoft Office XP Upgrade

REFERENCES

For additional information about upgrading Microsoft Office, visit the following Microsoft Web page:For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

290366 OFFXP: Setup May Remove Earlier Versions of Office

300655 OFFXP: Message to Provide Qualifying Upgrade Product When You Start an Office Program


Modification Type:MinorLast Reviewed:4/11/2006
Keywords:kbupdateissue kberrmsg kbnofix kbprb KB295346